Nationaal Cyber Security Centrum - Ministerie van Veiligheid en Justitie

Beveiligingsadvies

Kansniveau is gemiddeld Schadeniveau is gemiddeld NCSC-2017-0514 [1.07]

Kwetsbaarheid verholpen in sudo

16-06-2017 - De ontwikkelaars van sudo hebben een kwetsbaarheid verholpen.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

   #####################################################
  ##  N C S C ~ B E V E I L I G I N G S A D V I E S  ##
 #####################################################

######################## UPDATE 1.07 #############################

Titel           : Kwetsbaarheid verholpen in sudo
Advisory ID     : NCSC-2017-0514
Versie          : 1.07
Kans            : medium
CVE ID          : CVE-2017-1000367, CVE-2017-1000368
                  (http://cve.mitre.org/cve/)
Schade          : medium
                  Omzeilen van beveiligingsmaatregel
Uitgiftedatum   : 20170616
Toepassing      : Sudo
Versie(s)       : < 1.8.20
Platform(s)     : Linux

Update
   Er is exploitcode beschikbaar gemaakt voor deze kwetsbaarheid. Dit
   heeft geen impact op de inschaling. 

Samenvatting
   De ontwikkelaars van sudo hebben een kwetsbaarheid verholpen.

Gevolgen
   Een lokale kwaadwillende kan zich door het misbruiken van deze
   kwetsbaarheid verhoogde rechten verschaffen op het kwetsbare
   systeem.

Beschrijving
   - CVE-2017-1000367, CVE-2017-1000368
   Door een kwetsbaarheid in de wijze waarop het sudo proces het TTY
   nummer bepaalt van een onderliggend proces, kan een lokale
   kwaadwillende met sudo rechten willekeurige bestanden schrijven.
   Hiermee kan de kwaadwillende eventueel volledige rootrechten
   verkrijgen door bijv. bestanden als /etc/shadow of /etc/sudoers te
   overschrijven. Om de kwetsbaarheid te misbruiken moet het systeem
   SELinux geconfigureerd zijn en sudo SELinux ondersteunen.

Mogelijke oplossingen
   De ontwikkelaars van sudo hebben updates beschikbaar gemaakt om de
   kwetsbaarheid te verhelpen.
   
   Er is aangegeven dat de kwetsbaarheid met CVE-2017-1000367 in eerste
   instantie niet volledig is verholpen. Aan de hierdoor ontstane
   kwetsbaarheid is kenmerk CVE-2017-1000368 toegekend. Om deze
   kwetsbaarheid te verhelpen is een nieuwe update beschikbaar gemaakt
   met versienummer 1.8.20p2. Zie de volgende pagina voor meer
   informatie:
   
   https://www.sudo.ws/alerts/linux_tty.html
   
   -= CentOS =-
   CentOS heeft updates beschikbaar gesteld voor CentOS 6 en 7 om de
   kwetsbaarheden te verhelpen. U kunt deze updates installeren met
   behulp van het commando 'yum'. Voor meer informatie en een eventueel
   handmatige installatie, zie:
   
   https://access.redhat.com/errata/RHSA-2017:1382
   
   -= Debian =-
   Debian heeft updates van sudo beschikbaar gesteld voor Debian 8.0
   (Jessie) om de kwetsbaarheid te verhelpen. U kunt de aangepaste
   packages installeren door gebruik te maken van 'apt-get update' en
   'apt-get upgrade'. Meer informatie kunt u vinden op onderstaande
   pagina:
   
   https://www.debian.org/security/2017/dsa-3867
   
   -= Fedora =-
   Fedora heeft updates beschikbaar gesteld voor Fedora 24, 25 en 26. U
   kunt deze updates installeren met behulp van het commando 'dnf' of
   'yum'. Meer informatie over deze updates en over een eventueel
   handmatige installatie vindt u op:
   
   Fedora 24:
   https://lists.fedoraproject.org/archives/list
      /package-announce@lists.fedoraproject.org/message
      /VJLV6RSLKYRCGP4NKXMY4RECDUABZI4X/
   
   Fedora 25:
   https://lists.fedoraproject.org/archives/list
      /package-announce@lists.fedoraproject.org/message
      /V4SE3B7G7YYGF6OLKF4FAFG6BELOXL7B/
   
   Fedora 26:
   https://lists.fedoraproject.org/archives/list
      /package-announce@lists.fedoraproject.org/message
      /7F75IBM2JKI6BGFPTTXIKUULKHT7SNVW/
   
   -= OpenSUSE =-
   De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om
   de kwetsbaarheid te verhelpen in OpenSUSE Leap 42.2. U kunt deze
   aangepaste packages installeren door gebruik te maken van 'zypper'.
   U kunt ook gebruik maken van YAST of de updates handmatig downloaden
   van de SUSE FTP-server (ftp.suse.com). Voor meer informatie, zie:
   
   https://lists.opensuse.org/opensuse-security-announce/2017-05
      /msg00079.html
   
   -= Oracle Linux =-
   Oracle Linux heeft updates beschikbaar gesteld voor Oracle Linux 5,
   6 en 7. Meer informatie over deze updates en over een eventueel
   handmatige installatie vindt u op:
   
   http://linux.oracle.com/errata/ELSA-2017-1381.html en
   https://linux.oracle.com/errata/ELSA-2017-1382.html
   
   -= Red Hat =-
   Red Hat heeft updates beschikbaar gesteld voor Red Hat Enterprise
   Linux 6 en 7. U kunt deze updates installeren met behulp van het
   commando 'yum'. Meer informatie over deze updates en over een
   eventueel handmatige installatie vindt u op:
   
   https://access.redhat.com/errata/RHSA-2017:1382
   
   -= SUSE =-
   SUSE heeft updates beschikbaar gesteld om de kwetsbaarheid te
   verhelpen in SUSE 12. U kunt deze aangepaste packages installeren
   door gebruik te maken van 'YaST'. U kunt de packages ook handmatig
   downloaden van de SUSE FTP-server (ftp.suse.com). Voor meer
   informatie, zie:
   
   https://lists.opensuse.org/opensuse-security-announce/2017-05
      /msg00078.html
   
   -= Ubuntu =-
   Ubuntu heeft updates beschikbaar gesteld voor Ubuntu 14.04 LTS,
   16.04 LTS, 16.10 en 17.04 om de kwetsbaarheid te verhelpen. U kunt
   de aangepaste packages installeren door gebruik te maken van
   'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden
   op onderstaande pagina:
   
   https://www.ubuntu.com/usn/usn-3304-1/

Hyperlinks
   https://www.sudo.ws/alerts/linux_tty.html

Vrijwaringsverklaring
   Door gebruik van deze security advisory gaat u akkoord met de
   navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke
   zorg heeft betracht bij de samenstelling van dit beveiligingsadvies,
   kan het NCSC niet instaan voor de volledigheid, juistheid of
   (voortdurende) actualiteit van dit beveiligingsadvies. De informatie
   in dit beveiligingsadvies is uitsluitend bedoeld als algemene
   informatie voor professionele partijen. Aan de informatie in dit
   beveiligingsadvies kunnen geen rechten worden ontleend. Het NCSC
   en de Staat zijn niet aansprakelijk voor enige schade ten gevolge
   van het gebruik of de onmogelijkheid van het gebruik van dit 
   beveiligingsadvies, waaronder begrepen schade ten gevolge van de 
   onjuistheid of onvolledigheid van de informatie in dit
   beveiligingsadvies. Op dit beveiligingsadvies is Nederlands recht
   van toepassing. Alle geschillen in verband met en/of voortvloeiend
   uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief
   bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de
   voorzieningenrechter in kort geding.


-----BEGIN PGP SIGNATURE-----
Version: Encryption Desktop 10.3.2 (Build 16620)
Charset: utf-8

wsDVAwUBWUOpDyhuEbXFfhL2AQgXogv+NUPe4JdhdURCN7/CcKaEWlgzvd/VPNHa
6cWEJy8osRDooQOMkhDDbn32M7Cn7LRYDsGZ5Uq/pPBpACosP6p6Rgoy9OrbimiX
9VPm2BOjpMK1GeqFJHVPphv6m3+zJJ5yhIrphHFHKxYA4L1PIhgfDANEne+c5GUv
D8S7y6Luys8B83HghRWVcGLFSgMAQ0UDTZMv24ezEvZ0RfQtR6Ccf2ZORysLm7iG
KqsKy3ZY2SSAeSdL65lrxc7DGdkOgixyxYyaoxvT/Qo4DBeadEY6AlILOSOrTcuf
5A06dvINOvnEoYt+hHsQJ2TXP/28CllIG+pZgzc1/dk8VMzNb77zaNpOE81x5X/i
aG4XR//b4cEY+mW49pXDkhxlfeLeVif4x7NFMxmJM8tBFWL3UjbhOrEabPfHjNu6
gSekD67ns1C3MGxMU3yJAzf0egGT6RvPYxyQrHnOesNK4VDIGDrhuLyC8CmLsEmW
Tp/TSfYewTdZRhwFBhZGqrnHM08g5Lah
=ftAd
-----END PGP SIGNATURE-----

Over het NCSC

NCSCstill

CSBN 2017

CSBN 2017