Nationaal Cyber Security Centrum - Ministerie van Veiligheid en Justitie

Beveiligingsadvies

Kansniveau is gemiddeld Schadeniveau is hoog NCSC-2017-0966 [1.00]

Kwetsbaarheden verholpen in Ansible

14-11-2017 - Er zijn updates uitgebracht om kwetsbaarheden te verhelpen in Ansible. Een kwaadwillende kan de kwetsbaarheden misbruiken voor het verkrijgen van gevoelige informatie of mogelijk andere doeleinden.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

   #####################################################
  ##  N C S C ~ B E V E I L I G I N G S A D V I E S  ##
 #####################################################

Titel           : Kwetsbaarheden verholpen in Ansible
Advisory ID     : NCSC-2017-0966
Versie          : 1.00
Kans            : medium
CVE ID          : CVE-2016-8614, CVE-2016-8628, CVE-2016-9587,
                  CVE-2017-7481, CVE-2017-7550
                  (http://cve.mitre.org/cve/)
Schade          : high
                  Remote code execution (Administrator/Root rechten)
                  Toegang tot gevoelige gegevens
Uitgiftedatum   : 20171114
Toepassing      : Ansible
Versie(s)       : < 2.4.1.0
Platform(s)     : OpenSUSE

Samenvatting
   Er zijn updates uitgebracht om kwetsbaarheden te verhelpen in
   Ansible. Een kwaadwillende kan de kwetsbaarheden misbruiken voor het
   verkrijgen van gevoelige informatie of mogelijk andere doeleinden.

Gevolgen
   Een kwaadwillende kan de kwetsbaarheden misbruiken voor het
   verkrijgen van gevoelige informatie of mogelijk andere doeleinden.

Beschrijving
   - CVE-2016-8614
   De verificatie van ondertekende sleutels wordt door apt_key niet
   goed uitgevoerd. Er is niet beschreven wat de mogelijke impact is
   van deze kwetsbaarheid.
   
   - CVE-2016-8628
   Er bevindt zich een command-injectie-kwetsbaarheid in Ansible. Er is
   niet beschreven wat de mogelijke impact is van deze kwetsbaarheid.
   
   - CVE-2016-9587
   Een kwaadwillende die controle heeft over een client-systeem dat
   wordt beheerd via Ansible, en de mogelijkheid heeft om berichten
   richting de Ansible-server te versturen, kan deze kwetsbaarheid
   gebruiken voor het uitvoeren van willekeurige code op de
   Ansible-server onder de rechten van de Ansible-gebruiker.
   
   - CVE-2017-7481
   Er bevindt zich een kwetsbaarheid in Ansible met een is niet nader
   beschreven impact.
   
   - CVE-2017-7550
   Er bevindt zich een kwetsbaarheid in de jenkins-plugin waardoor
   wachtwoorden terecht kunnen komen in de logs van andere systemen.
   Een kwaadwillende kan deze kwetsbaarheid misbruiken voor het
   verkrijgen van gevoelige informatie.

Mogelijke oplossingen
   -= OpenSUSE =-
   De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om
   de kwetsbaarheden te verhelpen in OpenSUSE Leap 42.2 en Leap 42.3. U
   kunt deze aangepaste packages installeren door gebruik te maken van
   'zypper'. U kunt ook gebruik maken van YAST of de updates handmatig
   downloaden van de OpenSUSE downloadserver (download.opensuse.org).
   Voor meer informatie, zie:
   
   https://lists.opensuse.org/opensuse-updates/2017-11/msg00027.html

Vrijwaringsverklaring
   Door gebruik van deze security advisory gaat u akkoord met de
   navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke
   zorg heeft betracht bij de samenstelling van dit beveiligingsadvies,
   kan het NCSC niet instaan voor de volledigheid, juistheid of
   (voortdurende) actualiteit van dit beveiligingsadvies. De informatie
   in dit beveiligingsadvies is uitsluitend bedoeld als algemene
   informatie voor professionele partijen. Aan de informatie in dit
   beveiligingsadvies kunnen geen rechten worden ontleend. Het NCSC
   en de Staat zijn niet aansprakelijk voor enige schade ten gevolge
   van het gebruik of de onmogelijkheid van het gebruik van dit 
   beveiligingsadvies, waaronder begrepen schade ten gevolge van de 
   onjuistheid of onvolledigheid van de informatie in dit
   beveiligingsadvies. Op dit beveiligingsadvies is Nederlands recht
   van toepassing. Alle geschillen in verband met en/of voortvloeiend
   uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief
   bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de
   voorzieningenrechter in kort geding.


-----BEGIN PGP SIGNATURE-----
Version: Encryption Desktop 10.4.1 (Build 777)
Charset: utf-8

wsDVAwUBWgsfgihuEbXFfhL2AQga+wv8DJ2Q0C5nURJRqIIwuHpOC3Jg1Dj9y6D0
LtTqvN3I5zXngL48l0Hc0DEoji08ILLWy3iS0LET7IgORnHHfOw2clPWVg2v3LyU
DKM84QB0BKkt8r+pM+hFWJu7G0VwuoEw4CDxzrpQFpZrATBEJsr0HJ8BH2YWA2uE
uPN3QWRpl/+7Aox/9CsqQ4vBx6yYxvZzSuENrzzveqv6pN43pPJurTE9y81d08r2
0t/I4eOLeofqZxbOhiTUltKVJVJcID4TcjTp1dK/Jo4Yydv4H1UClsvLL6sh2wNT
/ZOwoa24Z5WEB9vnEXqmn2MZc6i15KtBJlEKqD/Tw6RuKZ5iV94IVv54QG7ah+Sb
eR2hIXSvTyYHoFMvOByhvA76I2eQ2vpvIQVuyiHpUFV/qFfLx6dYbwXecjopmH6O
CEym+THs9tgnh+naeuX98KAQo2wx6i8l38TC7KXAngIivaX77POdr5SuEne+yaBQ
rVwUVSU6dotV1NtwTVLAZEVJtDLU4JCn
=ZMZ9
-----END PGP SIGNATURE-----

Over het NCSC

NCSCstill

CSBN 2017

CSBN 2017